Friday, July 11, 2008

SongketMail Mail Transfer Agent (MTA) - Postfix

SongketMail Mail Transfer Agent (MTA) - Postfix

Postfix must support OpenLDAP

Check with postconf -m

[[email protected] yum.repos.d]# postconf -m
btree
cidr
environ
hash
ldap
nis
pcre
proxy
regexp
static
unix
---

If your are not using Dbmail. With Dovecot need to set MailDir in postfix main.cf

home_mailbox = Maildir/

----

List of dependencies for Postfix for Linux Centos 5.2

[[email protected] yum.repos.d]# yum deplist postfix
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
* extras: centosa3.centos.org
* base: centosw.centos.org
* updates: centosk2-msync-dvd.centos.org
* addons: centosw.centos.org
Finding dependencies:
package: postfix.i386 2:2.3.3-2
dependency: libz.so.1
provider: zlib.i386 1.2.3-3
dependency: libnsl.so.1
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: liblber-2.3.so.0
provider: openldap.i386 2.3.27-8.el5_1.3
provider: openldap.i386 2.3.27-8.el5_2.4
dependency: /usr/sbin/useradd
provider: shadow-utils.i386 2:4.0.17-13.el5
dependency: libc.so.6(GLIBC_2.1.3)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: libssl.so.6
provider: openssl.i686 0.9.8b-10.el5
provider: openssl.i386 0.9.8b-10.el5
dependency: libc.so.6(GLIBC_2.4)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: fileutils
provider: coreutils.i386 5.97-14.el5
dependency: cyrus-sasl >= 2.1.10
provider: cyrus-sasl.i386 2.1.22-4
dependency: /bin/sh
provider: bash.i386 3.2-21.el5
dependency: openssl
provider: openssl.i686 0.9.8b-10.el5
provider: openssl.i386 0.9.8b-10.el5
dependency: libc.so.6(GLIBC_2.1)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: perl(Getopt::Std)
provider: perl.i386 4:5.8.8-10.el5_0.2
provider: perl.i386 4:5.8.8-10.el5_2.3
dependency: perl(IO::File)
provider: perl.i386 4:5.8.8-10.el5_0.2
provider: perl.i386 4:5.8.8-10.el5_2.3
dependency: /bin/bash
provider: bash.i386 3.2-21.el5
dependency: perl(strict)
provider: perl.i386 4:5.8.8-10.el5_0.2
provider: perl.i386 4:5.8.8-10.el5_2.3
dependency: libresolv.so.2
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: /sbin/chkconfig
provider: chkconfig.i386 1.3.30.1-2
dependency: libc.so.6(GLIBC_2.3.4)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: libresolv.so.2(GLIBC_2.2)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: libc.so.6(GLIBC_2.2)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: sh-utils
provider: coreutils.i386 5.97-14.el5
dependency: perl(File::Find)
provider: perl.i386 4:5.8.8-10.el5_0.2
provider: perl.i386 4:5.8.8-10.el5_2.3
dependency: /usr/sbin/groupadd
provider: shadow-utils.i386 2:4.0.17-13.el5
dependency: rtld(GNU_HASH)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: libdb-4.3.so
provider: db4.i386 4.3.29-9.fc6
dependency: /usr/sbin/alternatives
provider: chkconfig.i386 1.3.30.1-2
dependency: setup >= 2.5.36-1
provider: setup.noarch 2.5.58-1.el5
dependency: libdl.so.2
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: libpcre.so.0
provider: pcre.i386 6.6-2.el5_1.7
dependency: libldap-2.3.so.0
provider: openldap.i386 2.3.27-8.el5_1.3
provider: openldap.i386 2.3.27-8.el5_2.4
dependency: libsasl2.so.2
provider: cyrus-sasl-lib.i386 2.1.22-4
dependency: libc.so.6(GLIBC_2.3)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: /sbin/service
provider: initscripts.i386 8.45.19.EL-1.el5.centos.1
dependency: openldap >= 2.0.27
provider: openldap.i386 2.3.27-8.el5_1.3
provider: openldap.i386 2.3.27-8.el5_2.4
dependency: libnsl.so.1(GLIBC_2.0)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: config(postfix) = 2:2.3.3-2
provider: postfix.i386 2:2.3.3-2
dependency: libc.so.6
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: libc.so.6(GLIBC_2.0)
provider: glibc.i686 2.5-24
provider: glibc.i386 2.5-24
dependency: pcre
provider: pcre.i386 6.6-2.el5_1.7
dependency: /usr/bin/perl
provider: perl.i386 4:5.8.8-10.el5_0.2
provider: perl.i386 4:5.8.8-10.el5_2.3
dependency: textutils
provider: coreutils.i386 5.97-14.el5
dependency: libcrypto.so.6
provider: openssl.i686 0.9.8b-10.el5
provider: openssl.i386 0.9.8b-10.el5
[[email protected] yum.repos.d]#

No comments:

My Blog List